PART-I: Functional English
SESSION 1: ORDERING FOOD AT A RESTAURANT RELEVANT KNOWLEDGE
Imagine that you are at a restaurant. The waiter has come to ask what you would like to have, and you want to order a
plate of vegetable chowmein. How would you place the order? Think about it and try to frame some sentences to do
so. When we place an order, there are some common terms used. Some of them are introduced here. Read aloud the
following terms:
 Starters - The first course in a meal, also called “appetizers” or “starters”. Usage: “I would like to have Fried
Vegetarian Momos for starters.”
 Main course - The primary or main dish in a meal.
Usage: “I would like to have Shahi Paneer, Chane Pindi, Raita and Rumali
 Roti for the main course.”
 Dessert - The final course of a meal – it may be fruits or a sweet dish.
Usage: “I would like to have Kheer for dessert.”
The above example can be used in different ways depending upon the type of the order placed by the customer and
the responses will change accordingly.
SESSION 2: MAKING RESOLUTIONS
RELEVANT KNOWLEDGE
Have you ever made a promise to yourself? A promise could be as simple as:
1.I will never lose my temper again.
2.I will try to study hard this year and get a 1st division.
3.I will talk less on my mobile.
4.I will help mother out with her household chores when she comes home tired from work.
5.I will get 95% in Math this year.
6.I will learn to speak properly in English within six months.
Think about what you would like to promise to yourself. These promises are actually what are known as your own
“resolution”. In the session, we will learn about this concept.
Simple future tense
The use of words like will and shall denote the future time of action.
Now read the following sentences:
Set A
1. I will tryto learn English well.
2.I willtry to see fewer movies.
3. I will learn three new words every day.
4. I will exercise every morning for 1 hour.
5. I will not carry forward any regrets.
6. I will keep my room neat and clean.
7. I will accept the terms and conditions.
8. He will not let you join.
9. But we will argue in your favor.
Now compare the above sentences with the following:
Set B
1. I try to learn English well.
2. I try to see fewer movies.
3. I learn three new words every day.
4. I exercise every morning for 1 hour.
5. I take care of the dogs in my colony.
6. I do not carry any regrets.
7. I keep my room neat and clean.

Do you see the difference between the two sets i.e. set A and B of sentences? The first set of sentences is in simple
future tense. The second set denotes a fact or a habit, and are all in the simple present tense.
Active and Passive Voice
Read the examples given below:
Active: The hair stylist changed the color of my hair.
Passive: The color of my hair was changed by the hair stylist.
Passive: I was praised by the headmaster.
Active: The headmaster praised me.
In certain sentences in the passive voice, the subject may not be mentioned:
1. You should do the work - The work should be done.
2. We completed the marathon at last - The marathon was completed at last.
3. Has she finished her homework? - Has her homework been completed?
Pronouns
In this session, you will learn how to make use of pronouns.
The reflexive pronouns discussed in this session are: myself, ourselves, themselves, yourself, yourselves, himself,
herself, and itself.
Reflexive pronouns are used usually in 3 situations:
Situation 1: When the subject and object are the same. For example:
1. I hurt myself.
2. The music group calls themselves “Dire Straits”.
3. He shot himself.
Situation 2: As the object of a preposition, when the subject and the object are the same.
For example
1. I bought a present for myself.
2. She did it by herself. (She did it alone)
3. That man is talking to himself.
Situation 3: When you want to emphasize the subject. For example:
1. I‟ll do it myself (No one else will help me).
2. They ate all the food themselves (No one else had any).
Simple Past Tense
In this session, you will learn how to make use of Simple Past Tense.
Read aloud the following sentences:
1. My grandmother loved to narrate the story of Ram and Ravan to me when I was young.
2. I used to listen eagerly to her.
3. She always left off the story at an interesting point, and said “I will tell you what happened after that tomorrow”.
4. I would eagerly wait for the next day to come.
5. The next day I would pester her to tell me what happens next.
6. I enjoyed the storytelling sessions with my grandmother very much.
7. I don‟t know if I will be able to entertain my grandchild in the same way.
8. Most probably I will not have many stories to tell or my grandchild will not be interested in listening to stories.
9. But I can surely say that telling stories helps to expand a child‟s imagination in a way that no other thing does.
10. I was exhausted.
11. It was a very tiring journey.
12. I had a tiring journey.
13. The journey exhausted me.

Adjectives and adverbs
1. I am ready to take the test. - Adjective
2. I am readily taking the test. - Adverb
3. She ran out of the room in a hasty manner. - Adjective
4. She ran out of the room hastily. - Adverb
5. I was happy when I received the certificate. - Adjective
6. I happily received the certificate. – Adverb
Here are some adjectives to describe a city:
 City: active, bustling, noisy, busy, clean, dirty, windy.
 Traffic: loud, congested, snarled.
 Buildings: old, shabby, rundown, crumbling, modern, futuristic, sleek, towering, squat.
 Buildings (walls): brick, stone, marble, glass, steel, graffiti-covered.
 Monuments, statues: stone, copper, carved, ancient, moss-covered, faded, green, bronze.
 Sidewalk: concrete, cement, slick, cracked, tidy, littered, swept.
 Paint: fresh, weathered, peeling.
 Signs: neon, weathered, worn, bright, welcoming, flashing.
 Buses, cars, taxis: belching, crawling, speeding, honking, waiting, screeching.
 People: hurried, bundled, smiling, frowning, eager, rushed.
 Now, try to describe your city using the above pointers.
Prepositions
A preposition is a word that links a noun and pronoun to other words in a sentence. For example:
1. We went to the market.
2. The market is just around the corner.
3. Many kinds of stores can be found at the market.
Prepositions are used as follows:
 Prepositions of time: at, on, in, during, since, until, by, etc. We reached the hostel at 9 pm. We reached the
hostel on Monday.
 We will reach the airport in an hour. Note: Use at for specific times, on for days and dates, and in for nonspecific times.
 Prepositions of place: at, on, in, over, above, under, beside, behind, etc.
 We went to the library. The library is on Hudson Lane. Note: Use at for specific places, on for roads, streets,
etc., and in for cities, countries, etc.
 Prepositions of direction: to, from, across, through, around, into, towards, etc. The electronics shop is across
the street. The cricketers went in that direction.
 Prepositions indicating other relationships: by, with, of, for, etc. This sari is made of silk. A surprise is waiting
for you.
Present Continuous Tense
The Present Continuous Tense is used to describe an action that is continuing at the moment.
1. I am walking.
2. She is preparing lunch for everyone.
The verb will always take the form “is/am/are+verb+ing” depending upon the subject.
1. He/she/it/Meena/Rajan is walking.
2. They/we/you/the people are walking.
3. I am walking.
Past continuous tense
The Past Continuous Tense describes an action that was happening at a time in the past. A verb in this tense
will always take the form:
Was/were + verb (+ing)
 I/she/he/it/Meena/Rajan/the man was walking.
 They/we/you/the people were walking.
 She was working on her painting.
 He was rehearsing for his performance.
 I am walking. - Present Continuous Tense






I was walking. - Past Continuous Tense
She/he/it/Tina is walking. - Present Continuous Tense
She/he/it/Tina was walking. - Past Continuous Tense
We/they/the people are working. - Present Continuous Tense We/they/the people were working. - Past
Continuous Tense



Future continuous tense.
The Future Tense describes an action that will be ongoing in the future. A verb in the future continuous tense
will always take the form:
“will+be+verb+ing”. For example:
 I will be reporting on the news channel tonight.
 He will be coming home at around 10.
 They will be working hard to win the match.
 You will be doing your homework.
Present Perfect Tense is used to describe an action which occurred recently.
 I have read the essay.
 She has taken breakfast.


Prepositions
 We are sitting in the dining room.
 We are inside the house.
 Put the mug inside the cardboard box.
 Pour some coffee into the mug.
 We sprinkled water on his head to wake him up.
Connectors and conjunctions
Connectors are words used to express relationship between ideas and combine paragraphs and sentences.
For example: but, also, however, moreover, firstly, next, then, therefore, in brief, still, for example, thus, of course,
certainly, hence, at the same time, on the contrary, etc.
Conjunctions are words used to connect phrases and words. For example: but, so, as, and, nor, yet, so, although,
though, because, either…or, neither…nor, as soon as, and or.
Note: Conjunctions can also be used as connectors.
Reported speech
Let‟s understand Reported Speech with the help of the following examples and explanations:
1. He said, “I am thirsty” - Direct Speech
2. He said he was thirsty - Reported Speech.
3. She said, “What are you doing?” - Direct Speech.
4. She asked me what I was doing - Reported Speech.
5. They said, “We have won the match” - Direct Speech.
6. They said they had won the match - Reported Speech.
Writing a job acceptance letter when you have received a job offer is one of the best and most pleasurable things to do
as it represents the culmination of all your efforts in searching for a new job.
A job acceptance letter is a letter that you write to a company which has offered you a job. In such a letter, the
following points are included in the given sequence:
 Written acceptance of the job offer.
 The terms and conditions of employment (salary, benefits, etc.).

Starting date of employment.
B.
Design a presentable RESUME (Bio-dada) to describe Name, Address, Photograph, Contact details, Professional
objective, Educational qualifications, Work experiences, Extra-curricular activities, Awards, Hobbies, etc and finally
Name, Signature & Date. Also write a Cover Letter for this Resume.
C.

Describe a telephonic conversation on an interview between an Employer and a candidate whose application has been
accepted for an interview, for a post (such as HR / Admin / Engineer / Financial Officer / Clerk / Manager).

PART-II: Word Processing
1. Alignment of text:
Step 1: Open an existing Word document or start a new document and type your text. The default layout is left
align, where text will be aligned to the left margin of the document.
Step 2: To change the layout of your text, select the text that you wish to change by using the mouse or
keyboard shortcuts.
Step 3: To centre the selected text, click on the „centre text‟ icon in the formatting ribbon at the top of the
document.
Step 4: To right align the selected text, click on the „right align‟ icon. This will move all highlighted text so that
it‟s aligned to the right.
Step 5: To „justify‟ text so that it is aligned to both right and left, click on the „justify‟ icon.
Step 6: It‟s also possible to change selected text using a combination of keyboard shortcuts, which some
people find easier than using the mouse.
To make text centered, select and highlight the text first, then hold down Ctrl (the control key) on the keyboard
and press E.
 To make text right aligned, select and highlight the text first, then hold down Ctrl (the control key) on the
keyboard and then press R.
 To make text justified, select and highlight the text first, then hold down Ctrl (the control key) on the
keyboard and then press J.
 To make the text left aligned again, press and hold down Ctrl on the keyboard and press L.
2. Indentation of Text:
To Use a pre-defined style:
Open the Styles and Formatting window (select: Format > Styles and Formatting from the pulldown menu).
Place the text cursor in the text that you want to format as hanging indent (or have the cursor in an empty text
style and enter the text later)
 Double-click on the Hanging Indent choice in the Styles and Formatting window. This default style has a
hanging indent - but it also has a left margin offset of .19 inches.
(OPTION) To change the indent offset:
 After performing the above two steps, close the Styles and Formatting window.
 Place your cursor in the paragraph with the hanging indent.
 Choose Format > Paragraph
 Select the Indents & Spacing tab in the Paragraph window
 Click on the up and down arrows to adjust the Before text and First line measurements to adjust the offset of
the hanging indent.
Change paragraph indents and spacing:
 Select one paragraph or a group of paragraphs that you want to adjust.
 Click the Paragraph dialog box launcher on the Page Layout or Layout tab.
 If necessary, choose the Indents and Spacing tab.
 Choose your settings, and then choose OK.
3. Inserting Line Spacing: To change the line spacing to double spacing in the entire document, click
"Format," and then select "Paragraph." Click the "Line Spacing" drop-down menu, choose "Double," and then
click "OK." To change the spacing on a specific piece of text, highlight the text before adjusting the formatting.


4. Inserting Paragraph Spacing: Set 1-inch Spacing. Select the text you want to work with, then open the
Format menu and choose "Paragraph." You can change the space before the selected paragraph, after the
selected paragraph or between the selected lines to 1 inch using the options under the Indents
& Spacing tab. Click "OK" to confirm your settings ...
5. Inserting Header and Footer:
 Select File > Properties > Description, enter a title for your document in the Title area, and click OK to
close the dialog box.
 Add a header (Insert > Header > Default).
 Place the cursor in the header part of the page.
 Select Insert > Fields > Title.
6. Inserting Page Number :
 Place the cursor in the first paragraph of the new page.
 Choose Insert > Manual break.
 Page break is the default selected on the Insert Break dialog box.
 Choose the required page in the Style drop-down list.
 Check Change page number.

 Specify the page number to start from and then click OK
7. Inserting Symbols :
 Place the cursor in the location where you want the symbol to appear.
 On the Insert menu select Special Character.
 In the dialog that appears, choose Symbol from the Font list.The trademark symbol is available in a
Serif font (character 212) or in a San-Serif font (character 228). ...
 Click OK.
8. Inserting Pictures:
 Click in the Open document where you want the image to appear.
 Choose Insert > Picture > From File from the menu bar.
 On the Insert Picture dialog, navigate to the file to be inserted, select it, and click Open.
9. Inserting Shapes:
 Click the shape, hold down your left mouse button and drag the shape to the place on the document
where you want it to appear. Resize the shape by clicking and dragging one of the handles along
the shape's edge. Move to the top of the drawing window, and review the drop-down menus on the
"Line and Filling" toolbar.
10. Inserting Tables:
 To insert a table with more control over the settings and properties, use the Insert Table dialog box.
 To open the dialog box, select Table → Insert → Table or Ctrl + F12 or left click the Table icon.
 The AutoFormat button at the bottom of the dialog box opens the AutoFormat dialog box:
11. Formatting Text :
 Press F11 to open the Styles and Formatting window.
 On the Paragraph Styles page of the Styles and Formatting window, right-click on Default in the list
and select Modify.
 On the Paragraph Style dialog, go to the Text Flow page.
 Under Hyphenation, select or deselect the automatically option.
12. Page Break:
 Press F11 to open the Styles and Formatting window.
 On the Paragraph Styles page of the Styles and Formatting window, right-click on Default in the list
and select Modify.
 On the Paragraph Style dialog, go to the Text Flow page.
 Under Hyphenation, select or deselect the Automatically option.
13. Changing case:
 Highlight the text you want to change.
 Once highlighted click Format and then Change Case.
 Within Change Case select the type of capitalization you want.
14. Object Linking Embedding (OLE):
 Select Insert > Object > OLE object from the main menu. This opens the dialog below.
 Select Create new and select the object type among the available options.
 Click OK. An empty container is placed in the slide.
 Double-click on the OLE object to enter the edit mode of the object.

PART-III: Web Technology
1.

Basic Terminologies:
Browser: A web browser (commonly referred to as a browser) is a software application for accessing information on the
World Wide Web. Each individual web page, image, and video is identified by a distinct URL, enabling browsers to retrieve
and display them on the user's device.
Web Address / URL: A Uniform Resource Locator (URL), colloquially termed a web address, is a reference to a location on a
computer network and a mechanism for retrieving it. URLs occur most commonly to reference web pages (http), but are also
used for file transfer (ftp), email (mailto), database access (JDBC), and many other applications.
Web Server: Web server refers to server software, or hardware dedicated to running said software, that can serve contents
to the World Wide Web. A web server processes incoming network requests over the HTTP protocol (and several other
related protocols)
WWW: The World Wide Web (abbreviated WWW or the Web) is an information space where documents and other web
resources are identified by Uniform Resource Locators (URLs), interlinked by hypertext links, and accessible via the Internet.
The World Wide Web has been central to the development of the Information Age and is the primary tool billions of people
use to interact on the Internet.
Protocol: Protocols are rules that control over the transactions of files and communications in the Internet.
Examples:
 The Internet Protocol (IP) is the principal communications protocol for transferring files (packets) across network

boundaries.
The Hypertext Transfer Protocol (HTTP) is an application protocol for distributed, collaborative, and hypermedia
information systems.
 Transmission Control Protocol (TCP) is one of the main protocols of the Internet protocol. It originated in the
initial network implementation in which it complemented.
 The File Transfer Protocol (FTP) is a standard network protocol used for the transfer of computer files between a
client and server on a computer network.
Internet Connection: Internet access is the ability of individuals and organizations to connect to the Internet using computer
terminals, computers, and other devices; and to access services such as email and the World Wide Web. Various
technologies, at a wide range of speeds have been used by Internet service providers (ISPs) to provide this service.
Internet access was once rare, but has grown rapidly. In 1995, only 0.04 percent of the world's population had access, In the
first decade of the 21st century, many consumers in developed nations used faster broadband technology, and by 2014, 41
percent of the world's population.


2.

3.

Internet Access: Internet access is the ability of individuals and organizations to connect to the Internet using computer
terminals, computers, and other devices; and to access services such as email and the World Wide Web. Various
technologies, at a wide range of speeds have been used by Internet service providers (ISPs) to provide this service.
Search Engine: It is a service that allows Internet users to search for content via the World Wide Web (WWW). A user enters
keywords or key phrases into a search engine and receives a list of Web content results in the form of websites, images,
videos or other online data. The list of content returned via a search engine to a user is known as a search engine results
page (SERP).
Online Chat: It may refer to any kind of communication over the Internet that offers a real-time transmission of text
messages from sender to receiver. Chat messages are generally short in order to enable other participants to respond
quickly. Thereby, a feeling similar to a spoken conversation is created, which distinguishes chatting from other text-based
online communication forms such as Internet forums and email.
Audio / Video chat is a one-on-one visual communication between two Internet users. Skype popularized video as well as
audio chats. It lets any two people around the globe to place a video call to each other. For this, all they need is a computer,
the Skype application, and a good Internet connection.
The World Wide Web (WWW): The Web is nothing more than a collection of files stored at locations throughout the world.
These files are written using a special language known as the Hypertext Markup Language (HTML). A file written using this
language will contain text which forms the information content of the file, together with instructions which define how the
text is to be displayed; for example, HTML contains a facility whereby blocks of text are specified to be displayed as bullet
points.
e-Commerce: Electronic commerce The ability to do business without the usual constraints of time or distance make ecommerce one of the most important services provided by the Internet. With the single click of a mouse, online customers
can purchase almost anything day or night from the comfort of their own home. Since human interaction and the need for
an actual brick-and-mortar location do not figure into the e-commerce equation, doing business on the Internet does not
cost as much. This levels the business playing field and allows small business to compete with large corporations.
e-Shopping or Online shopping is a form of e-commerce which allows consumers to directly buy goods or services from a
seller over the Internet using a web browser. Consumers find a product of interest by visiting the website of the retailer
directly or by searching among alternative vendors using a shopping search engine, which displays the same product's
availability and pricing at different e-retailers. As of 2016, customers can shop online using a range of different computers
and devices, including desktop computers, laptops, tablet computers and smart phones.
E-Banking: e-Banking is a product designed for the purposes of online banking that enables you to have easy and safe access
to your bank account. E-banking is a safe, fast, easy and efficient electronic service that enables you access to bank account
and to carry out online banking services, 24 hours a day, and 7 days a week.
With this service one can save his/her time by carrying out banking transactions at any place and at any time, from your
home or office, all you need is internet access. E-banking enables the following:
•
•
•
•
•
•


Accurate statement of all means available in your bank account
Statement of current account, credits, overdrafts and your deposits
Execution of national and international transfers in various currencies
Execution of all types of utility bill payments (electricity, water supply, telephone bills, etc..)
Carrying out customs payments
Electronic confirmation for all transactions executed by E-banking
Management of credit card

e-Learning System: A learning system based on formalised teaching but with the help of electronic resources is known as Elearning. While teaching can be based in or out of the classrooms, the use of computers and the Internet forms the major
component of E-learning. E-learning can also be termed as a network enabled transfer of skills and knowledge, and the
delivery of education is made to a large number of recipients at the same or different times. Earlier, it was not accepted
wholeheartedly as it was assumed that this system lacked the human element required in learning.
Online Reservation System: A computer reservation system or central reservation system (CRS) is a computerized system
used to store and retrieve information and conduct transactions related to air, train and bus travel, hotels, car rental, or
other activities. Originally designed and operated by airlines. Global distribution systems (GDS) book and sell tickets for
multiple airlines. Most airlines have outsourced their CRSs to GDS companies, which also enable consumer access through
Internet gateways. These are also used to relay computerized information for users in the hotel industry, making reservation
and ensuring that the hotel is not overbooked.

e-Information
1.

E-Mail: Electronic mail (email or e-mail) is a method of exchanging messages ("mail") between people using electronic
devices. Email first entered limited use in the 1960s and by the mid-1970s had taken the form now recognized as email.
Email operates across computer networks, which today is primarily the Internet. Some early email systems required the
author and the recipient to both be online at the same time, in common with instant messaging. Today's email systems
are based on a store-and-forward model. Email servers accept, forward, deliver, and store messages. Neither the users
nor their computers are required to be online simultaneously; they need to connect only.
Mail Id: Email id is an email address that is unique in the associated application and can be used as login id or unique
identifier of the account.
How to send and receive e-mail
E-mail Program: To send and receive e-mail messages, you can use an e-mail program, also known as an e-mail client,
such as Microsoft Outlook or Mozilla Thunderbird. When using an e-mail client, you must have a server that stores and
delivers your messages, which is provided by your ISP or in some cases, another company. An e-mail client needs to
connect to a server to download new e-mail, whereas email stored online (see next section) updates automatically when
you visit the site.
E-mail Online: An alternative way of sending and receiving e-mail (and the more popular solution for most people) is an
online e-mail service or webmail. Examples include Hotmail (now Outlook.com), Gmail, and Yahoo Mail. Many of the
online e-mail services, including the ones we just mentioned, are free or have a free account option.
Writing an e-mail: When writing an e-mail message, it should look something like the example window below. As you
can see, several fields are required when sending an e-mail:
The field is where you type the e-mail address of the person who is the recipient of your message.
The field should contain your e-mail address.
If you are replying to a message, the and From fields are automatically filled out; if it's a new message, you'll need to
enter them manually.
The Subject should consist of a few words describing the e-mail's contents. The Subject lets the recipient see what the email is about, without opening and reading the full e-mail. This field is optional.
The CC ("Carbon Copy") field allows you to specify recipients who are not direct addressees (listed in the "To" field). For
instance, you can address an email to Jeff and CC Linda and Steven. Although the e-mail is addressed to Jeff, Linda and
Steven will also receive a copy of the message, and their addresses will be visible to Jeff, and to each other. This field is
optional.
The BCC ("Blind Carbon Copy") field is similar to CC, except the recipients are secret. Each BCC recipient will receive the
e-mail, but will not see who else received a copy. The addressees (anyone listed in the "To" field) remain visible to all
recipients. This field is optional.
Finally, the Message Body is the location you type your main message. It often contains your signature at the bottom;
similar to a hand-written letter.
When referring to e-mail, an attachment is a file sent with an e-mail message. An Attachment can be a picture, a word
document, a movie, a sound file, an Excel document, or any other file that requires another program to open it.
What makes a valid e-mail address?
There are several rules that an e-mail address must follow to be valid:


As mentioned earlier, an e-mail must have a username followed by an @ (at sign) which is followed by the
domain name with a domain suffix.



The username cannot be longer than 64 characters long, and the domain name cannot be longer than 254
characters.



There should be only one @ sign in an e-mail address.



The space and special characters: ( ) , : ; < > \ [ ] are allowed. Occasionally, a space, backslash, and quotation
mark work but must be preceded with a forward slash. Although valid, some e-mail providers do not allow
these characters.



The username and e-mail addresses as a whole cannot begin or end with a period.



The e-mail must not have two or more consecutive periods.

Social Impacts of I.T.
Definitions:
Malware, or malicious software, is any program or file that is harmful to a computer user. Malware includes computer
viruses, worms, Trojan horses and spyware. These malicious programs can perform a variety of functions, including stealing,
encrypting or deleting sensitive data, altering or hijacking core computing functions and monitoring users' computer activity
without their permission.
A Computer Virus is a type of malicious software program ("malware") that, when executed, replicates itself by modifying
other computer programs and inserting its own code. When this replication succeeds, the affected areas are then said to be
"infected" with a computer virus.
A Computer Worm is a standalone malware computer program that replicates itself in order to spread to other computers.
Often, it uses a computer network to spread itself, relying on security failures on the target computer to access it.
In computing, a Trojan Horse is a program that appears harmless, but is, in fact, malicious. Unexpected changes to computer
settings and unusual activity, even when the computer should be idle, are strong indications that a Trojan is residing on a
computer.
Spyware is software that aims to gather information about a person or organization without their knowledge, that may send
such information to another entity without the consumer's consent, or that asserts control over a device without the
consumer's knowledge. Spyware is mostly used for the purposes of tracking and storing Internet users' movements on the
Web and serving up pop-up ads to Internet users. Whenever spyware is used for malicious purposes, its presence is typically
hidden from the user and can be difficult to detect.
Spam is electronic junk mail or junk newsgroup postings. Some people define spam even more generally as any unsolicited
email. However, if a long-lost brother finds your email address and sends you a message, this could hardly be called spam,
even though it is unsolicited. Real spam is generally email advertising for some product sent to a mailing list or newsgroup.
Computer Hack refers to someone (hacker) who develops, changes or attempts to circumvent computer security hardware
or software. This can either happen for negative (criminal) or positive reasons. Criminal hackers develop computer malware
or spyware to gain access to confidential information.
And Crack refers to the means of achieving software cracking, for example a stolen serial number or a tool that performs
that act of cracking.
Antivirus software (anti-virus software or AV software), also known as anti-malware, is a computer program used to prevent,
detect, and remove malware.
There are advantages using Information and Communication Technology:
Communication: Speed/time and money can be saved because it is much quicker to send/share information around.
Communication is more efficient to contact either business partners or friends and family members all over the world. ICT
expands availability for communications. Social network sites and Social media such as Skype allows making videoconference calls with immediate response. Messages can be send to numerous people/companies across distances. Lives
have been affected by ICT in most positive way's bringing families together across the world.
Cost Effectiveness: Numerous offers from telecommunication companies and smart phones therefore making far cheaper
than in the past. For business ICT saves incredible amount of money on business flights and accommodations. Only few years
ago there was no way to send free message through to the phone, but now people uses social network for free
communication e.g. Viber, Skype, Face book. Saving time and money for petrol as people can go shopping from home
through online shopping.

Greater Availability: Websites are open for communication in every minute of the year. This means that a business can be
open anytime anywhere giving a customer the capability to make purchase from different sites and different countries.
Bridging the Cultural Gap: Greater access to the ICT has helped to build the bridges between different cultures giving them
opportunity to exchange views and ideas. Also, educate both sides of communication bridge thereby increasing awareness
and reducing prejudice.
Creation of Jobs: The best advantage of ICT has been a creation of new and interesting jobs in IT sectors. Computer
programmers, web designers etc. have great employment opportunities created through the advancement of technology.
Education: There is new opportunity for further education to improve qualification in so many economic sectors. A degree
can be completed online from person's home. It is possible to hold a job and still do degree.
Impact of ICT in Society:
Advancements in technology have had a huge impact on the entertainment industry. The growing popularity of downloading
and streaming content has affected the traditional supply chain, ie the process of getting a product made and into the hands
of a consumer.
Working at a computer for long periods of time carries certain health risks. Taking frequent screen breaks and exercising
your eyes are advisable for anyone who works on computers all day.
Technology can mean that certain roles in a company are no longer required. New jobs are created but it is uncertain
whether ICT has created or reduced opportunities in the long term.
ICT can benefit the environment, for example it has given people the option to work from home, reducing the need to travel
into work. However, it can have a negative impact. Disposing of old equipment is a particular problem. One of the answers is
recycling and the law states that companies must recycle their old equipment.

PART-IV: Database Concept
Database management System
A database management system is a software package with computer programs that controls the creation, maintenance, and use
of a database. It allows organizations to conveniently develop databases for various applications. A database is an integrated
collection of data records, files, and other objects. A DBMS allows different user application programs to concurrently access the
same database.
Well known DBMSs are: Oracle, IBM DB2, Microsoft SQL Server, Microsoft Access, PostgreSQL, MySQL, FoxPro, and SQLite.

Tables and Key Field:
A table is a set of data elements (values) that is organized using a model of vertical columns (which are identified by
their name) and horizontal rows. A table has a defined number of columns, but can have any number of rows. Each
row is identified by the values appearing in a particular column identified as a unique key index or the Key Field.
Columns or Fields:
A column is a set of data values of a particular simple type, one for each row of the table.
Rows or records or Tuples:
A row also called a record or tuple represents a single, data item in a table. in simple terms, a database table can be visualized as
consisting of rows and columns or fields. Each row in a table represents a set of related data, and every row in the table has the
same structure.
Data types:
Datatypes are used to identify which type of data (value) we are going to store in the database. Fields themselves can be of
different types depending on the data they contain. Data types in Open Office base is broadly classified into five categories listed
below. Numeric Types
Alphanumeric Types
Binary Types
Date time
Other Variable types

Client Table

One client,
three orders for
that client.

ClientID

Name

Address

Phone

0000001

Sheela Arora

xxxxxxnoida

2444490

0000002

Vaibhav Mittal

xxxxGhaziabad

2443358

0000003

Saurabh tayal

xxxxnew Delhi

2678945

0000004

Prashant Singh

xxxxRohtak

6784534

Primary Key
Sales Table
OrderID

ClientID

SaleDate

ItemsBought

000789

0000001

01/11/12

3

000790

0000002

01/11/12

4

000791

0000003

02/11/12

12

000792

0000002

02/11/12

23

000793

0000004

02/11/12

4

000794

0000001

03/11/12

18

000795

0000002

03/11/12

45

Primary Key

In the example here, the field ClientID occurs once in the Client table, but since one client can place many orders, it occurs a
number of times in the Sales table. Since we cannot have an order without a customer, we call Client the parent and Sales the
child table. Related tables like these share a common field. You store data about people once, but refer to those people many
times in the database.
This unique field is called the primary key (PK). A primary key is a unique value that identifies a row in a table. in our example,
ClientID is the primary key in the Client table. Primary Keys are also indexed in the database, making it faster for the database to
search for a record.

The referred field ClientID which occurs in the Sales table is called the foreign key (FK). Hence, the foreign key identifies a column
or set of columns in one (referencing) table that refers to a column or set of columns in another (referenced) table.
The “one” side of a relation is always the parent, and provides the PK attributes to be copied. The “many” side of a relation is
always the child, into which the FK attributes are copied. Memorize it: one, parent, PK; many, child, FK.
Another point to remember is that the end users will/may never have direct access to the database. they can only see what you
permit them to and can select only from the options you give them.
To start & open a Database:
 You launch the OpenOffice Base Application by doing the following:
 Click Start>Programs>OpenOffice.org 3.4.1>OpenOffice.org Base. You should are guided through the Database Wizard
for creating a database. You will see a dialog box.
 You can create a new database by selecting the option Create a new database.
 Open an existing database file.
 Click Next. A dialog box
 Click Finish and Save As dialog box.
 Specify a name for the database in the File name: field and click Save.
 After specifying the field name and data type for the field variables, save the table by clicking on File>Save
 Specify the field name and the data type for each field name. For example, the table contains Name field and the data
type of the Name is TEXT [VARCHAR]. You can specify the length of the field value.
 After specifying the field name and data type for the field variables, save the table by clicking on File>Save

Field Name

Data type

Length

Name

VARCHAR

50

Rollno

Iintger

3

DOB

Date

DD/MM/YY

Class

Char

1

Phone

Integer

10

Email

VARCHAR

75

Colour

VARCHAR

15

Location

VARCHAR

30






Specify the table name. The default name is table1.
Click oK. A dialog box appears.
You are asked to set a primary key for the table you just created. You can select the appropriate option to set the
primary key or leave the table without a primary key.
If you click Yes, the application will set the primary key for the first field created automatically. If you click No,

Model Questions:
1.

Change the verbs in brackets to Present Perfect Tense and fill in the blanks:
[5/6 marks]
Two examples are given below.
•
I have driven a car.
•
She has driven a car.
A: Hello! My name is Akanksha from ABC Consultants. May i speak to Ms Kavya, please?
B: Kavya _______________ (leave) the office. May I take a message?
A: Well, our company _______________ (plan) a camp at Siri Fort this Saturday. Would she be interested in attending it?
B: Sure! in fact, i would also be interested. We _______________ (attend) such camps before. We found them useful.
A: That’s good. Can you give me your name and contact number as well?
B: My name is Manisha and my contact number is 9987654321. Some of my other friends _______________ (volunteer) at such
camps before. Would you like me to ask them to come along?
A: That’s great! You can ask them to call me on the same number if they need more information in this regard.
B: Ok. I will tell Kavya you called. Bye!
A: Bye
2. Write steps to apply: (i) Alignment (ii) Indentation (iii) Header-Footer (iv) Inserting Picture (v) paragraph
[1/2 marks]
3. Design Bio-Data in formatted form using Table
[5/6 marks]
4. Write an description of a telephonic interview for a post of job
[4/5 marks]
5. Write an application to introduce e-Learning infrastructure at your institution describing the benefits of if.
[4/5 marks]
6. Define: Worm, Malware, Spyware, Spam, Web Server
[2/3 marks]
7. Short notes on: WWW, Web Access, e-Mail, URL, Textual/Audio/Video chatting.
[3/4 marks]
8. Search Engine is now to guide to make information available. Write your opinion?
[3/4 marks]
9. What is a valid e-mail id? Write an email to your class teacher about your absence in next 2 days.
[3/4 marks]
10. How has e-Governance become popular? Express your view.
[3/4 marks]
11. GOOD and BAD Impact of I.T (Information Technology) in Society.
[4/5 marks]
12. How to use make a safe use of internet in daily life? Describe any 3 points.
[4/5 marks]
13. How ITC is changing our life?
[4/5 marks]
14. What is threat on computer? Write your view on: Virus / Worms / Trojan Horse / Spyware
[2/3 marks]
15. What is hacking of a computer? How is it different from cracking?
[2/3 marks]
16. Short Answer Questions
a) List the data types used in a DBMS /RDBMS?
b) State the relationship and difference between a primary and foreign key?
c) List datatypes available in numeric Datatype?
d) List datatypes available in Alphaumeric Datatype?
e) List datatypes available in numeric Datatype?
f) List datatypes available in Data Datatype?
17. Fill in the blanks:
a) A ___________ is a set of data elements that is organized using a model of vertical columns and horizontal rows.
b) A _________ is a set of data values of a particular simple type, one for each row of the table.
c) A ___________ represents a single, data item in a table.
d) _____________ are used to identify which type of data we are going to store in the database.
e) A ____________ is a unique value that identifies a row in a table.

###
Please Refer ‘DATA-BASE’ chapter of the book as given and download it from:
http://www.indoaryan.org

